MP3 wierdness.

Richard Lotz rlotz at u.washington.edu
Thu May 11 22:20:52 PDT 2000


Well, if the sun you used seemed to play OK then why not try decoding the
mp3 to wav (dump it to /tmp if you are short on space) then re-encode
it. Also, what version of mpg123 are you using? And what was used on the
sun to play the file?

-richard

--------------------------------------------------------------
Richard Lotz rlotz at u.washington.edu
http://students.washington.edu/rlotz ICQ: 12348088


On Fri, 12 May 2000, Steve Juranich wrote:


> Okay, I tried playing the file with mpg123, and here's what I got.

>

> Junk at the beginning

> MPEG 1.0 layer III, 192 kbit/s, 44100 Hz joint-stereo

> Illegal Audio-MPEG-Header 0xfbb06493 at offset 0x134ec.

> Skipped 625 bytes in input.

> mpg123: Can't rewind stream by 129 bits!

> Illegal Audio-MPEG-Header 0xfbb06494 at offset 0x19b9f.

> Skipped 625 bytes in input.

> Illegal Audio-MPEG-Header 0xfbb06491 at offset 0x1d3dc.

> Skipped 625 bytes in input.

> Illegal Audio-MPEG-Header 0xfbb06493 at offset 0x2b745.

> Skipped 625 bytes in input.

> Illegal Audio-MPEG-Header 0xfbb0648a at offset 0x3bcea.

> Skipped 625 bytes in input.

> Illegal Audio-MPEG-Header 0xfbb0648e at offset 0x4dd75.

> Skipped 625 bytes in input.

> Illegal Audio-MPEG-Header 0xfbb06490 at offset 0x50222.

> Skipped 625 bytes in input.

> mpg123: Can't rewind stream by 50 bits!

> Illegal Audio-MPEG-Header 0xfbb0648e at offset 0x54def.

> Skipped 625 bytes in input.

> Illegal Audio-MPEG-Header 0xfbb06496 at offset 0x563f0.

> Skipped 624 bytes in input.

> mpg123_ms: Can't rewind stream by 53 bits!

> Illegal Audio-MPEG-Header 0xfbb0648c at offset 0x65d5a.

> Skipped 625 bytes in input.

> mpg123_ms: Can't rewind stream by 168 bits!

> Illegal Audio-MPEG-Header 0xfbb0648a at offset 0x79daf.

> Skipped 625 bytes in input.

> mpg123_ms: Can't rewind stream by 134 bits!

> Illegal Audio-MPEG-Header 0xfbb06490 at offset 0x81f48.

> Skipped 625 bytes in input.

> Illegal Audio-MPEG-Header 0xfbb06496 at offset 0x93fd3.

> Skipped 625 bytes in input.

> Illegal Audio-MPEG-Header 0xfbb0648c at offset 0xa6f0a.

> Skipped 625 bytes in input.

> Illegal Audio-MPEG-Header 0xfbb06491 at offset 0xaa263.

>

> Any suggestions, or is this file hosed?

>

> Thanks.

>

> --Steve J.

>

> Steve Juranich wrote:

> >

> > So I got this MP3 from the internet. When I play it on my Sun machine in the

> > lab, it sounded great (I had to delete it, stinking quotas). But when I try

> > and play it at home, the file sounds funny. The music will speed up, then

> > slow down. It sounds like someone is playing the song on a record player, but

> > someone keeps playing with the speed control knob (yes, I *am* old enough to

> > remember record players).

> >

> > I've tried playing the same file with both KMPG and freeamp. Neither

> > application gives good results.

> >

> > My sound card is a standard SB64. I haven't had any problems with it

> > otherwise. I can even play other MP3's with it.

> >

> > Does anybody have an idea about what might be going on?

> >

> > Thanks.

> >

> > --Steve J.

>

> --

> Steve Juranich

> Senior, Electrical Engineering, University of Washington

> sjuranic at ee.washington.edu

> http://students.washington.edu/sjuranic

>




More information about the Linux mailing list