xfs dead but subsys locked

Thomas Anderl tomathie at u.washington.edu
Mon Jul 16 11:54:19 PDT 2001


Hi All,

I'm running RH6.2 and up until this morning, it's been running just fine.
I have it start into X automatically, so I usually turn the machine on,
and come back after a couple of minutes to the X login screen. This time,
however, when I came back, it gave me a console login.

running startx gives:

<errors>
(many SVGA messages that I'm pretty sure are just info)
_FontTransSocketUNIXConnect: Can't connect: errno = 111
failed to set default font path 'unix/:-1;
Fatal server error:
could not open default font 'fixed'

When reporting a problem related to a server crash, please send the full
server output, not just the last messages

X connection to :0.0 broken (explicit kill or server shutdown)
</errors>


So I look this up, and it looks like the problem is probably with xfs. I
run:
"/etc/rc.d/init.d/xfs status"
and it tells me:
"xfs dead but subsys locked"

Some solutions I saw out on the internet that I tried but didn't
work were:

(1) rm /var/lock/subsys/xfs

(2) change the port that xfs is using along with the port that X uses to
connect to xfs.

(3) make sure there is space on both /tmp and /. Well, /tmp is on the
same partition as / and df -m gives:
Filesystem 1M-blocks Used Available Use% Mounted on
/dev/sda1 4918 1300 3368 28% /
/dev/sda6 2602 90 2380 4% /kerry

so I don't think that space is an issue.



(4) try starting xfs from the command line to see what happens.

# xfs
eth0: Promiscuous mode enabled.
# ps -aux | grep xfs
#

So this is what I've tried, with no luck. One thing that I don't think is
related, but I'm not sure: /log/messages contains:

rpc.lockd: lockdsvc: Connection refused
nfslock: rpc.lockd startup failed

and a little later...

portmap: RPC call returned error 111


Any ideas how to get X to start again?

Thanks,

Tom

-------------------------------------------------------------------------------



More information about the Linux mailing list