Xwindows

J. Kyllo jkyllo+lug at echospiral.com
Wed Mar 28 16:28:13 PST 2001


Hmm. In /var/log there all kinds of logs. In theory, of course. Anyway,
the 'secure' log should have messages about valid (and invalid, I
assume) logins. Check that to see if the logins are actually
working. Also, there should be XFree86.*.log files in there that you
could check. They're usually just the server output but you never
know. I'm actually very unfamiliar with Xdm and it's cousins so I'm not
sure where else to go looking.

-Jeff

On Wed, 28 Mar 2001, Benjamin Honsinger wrote:


> df claims that I am only using 93% of my 540MB HDD. Would that be causing my

> problems with X-windows? I have a bigger HDD I am planning to swap in

> eventually, but the real problem I have right now is with getting X to work.

> The computer is used almost exclusively for web browsing, so without netscape

> it is kinda useless. I did actually get X to work by using a default of

> runlevel 3, but switching to runlevel 3 after booting into runlevel 5 did not

> work for some reason. So now my real question is how to get linux to work

> properly in runlevel 5 (as mentioned before, it would appear to accept a login,

> then just go back to the login screen).

>

> - Ben

>

> On Wed, 28 Mar 2001, you wrote:

> > What does the command df report? That will tell you how much disk space

> > is free on each of your mounted partitions. It could be that your home

> > partition (if it isn't huge) is full. With a small one (I used to use

> > 100M and a seperate partition for all of my actual data) netscape will

> > fill it up with it's cache even though you tell it to limit itself.

> >

> > -Jeff

> >

> > On Wed, 28 Mar 2001, Benjamin Honsinger wrote:

> >

> > > Something strange is happening. I have a computer that before today worked

> > > fine, and nothing has been changed on it. It is setup to start on runlevel 5,

> > > and that works. However, when you login, it looks like it is going to work

> > > (changes screen, etc) but it switches back to the graphical login.

> > > So I tried booting in runlevel 3, but then when I type startx I get

> > >

> > > xauth: error locking /home/student/.Xauthority

> > > hostname: unknown host

> > > Perhaps you do not have console ownership?

> > >

> > > The same thing happens when I try and run x as root, except it doesn't ask the

> > > question about console ownership. This has me stumped. I've nosed around on the

> > > Xfree86 web page, and in the LDP, but I haven't found anything useful. Anyone

> > > have some suggestions I could try, they would be appreciated! =) Just as a

> > > note, it if matters I think I am running dangerously low on disk space. And

> > > also, I believe the error X gives is errno 111.

> > >

> > > - Ben

> > >

>




More information about the Linux mailing list