[linux] Problem with big big hard drive

Dan Sanderson lists at dansanderson.com
Sun May 25 00:04:35 PDT 2003


Addendum (no I didn't fix it 5 minutes after I posted this time :) :
The Matrox ATA/133 PCI card (a Promise card) is interesting: on boot up,
after the BIOS found all the drives for the on-board IDE controller, the
new card displayed its own screen where it detected the new drive as a
primary on its IDE1 (where I put it). Everything else started up fine.
However, Linux didn't automatically set up hde as I was hoping it would.

/proc/ide does not contain anything new, only ide0, ide1 (the on-board
controllers), hda (ide0/hda) (my boot drive), hdc (ide1/hdc) (an ATAPI
Zip drive), hdd (ide1/hdd) (my DVD-ROM drive), and the drivers file
("ide-disk version 1.10"). If everything worked automatically, I would
have expected an ide2 and ide3, as well as hde (ide2/hde). No such luck.

/proc/pci shows the card just fine:
Bus 0, device 13, function 0:
Unknown mass storage controller: Promise Technology, Inc. 20269 (rev 2).
IRQ 9.
Master Capable. Latency=64. Min Gnt=4.Max Lat=18.
I/O at 0xd800 [0xd807].
I/O at 0xdc00 [0xdc03].
I/O at 0xe000 [0xe007].
I/O at 0xe400 [0xe403].
I/O at 0xe800 [0xe80f].
Non-prefetchable 32 bit memory at 0xe0000000 [0xe0003fff].

More searches about Linux and the Promise U133 show posts from people
that have had success using kernel 2.4.19 (I'm at 2.4.18), though no
explicit mention that 2.4.18 is required for this (just that everyone
seems to be using it). The kernel changelog mentions Promise 20276 was
added with 2.4.19, which, given the model number difference (20269
mentioned in /proc/pci), isn't enough to convince me to break from
Debian stable to upgrade to 2.4.20 (though I suppose it should be
considering 2.4.20 is considered the "production" kernel).

Someone seems to think that if the kernel is compiled with ide-mod as a
module, then /etc/modules.conf could have options ide-mod
options="ide2=ata66 ide3=ata66" (or to test, modprobe ide-mod
options="ide2=ata66 ide3=ata66"). Someone correct me if I'm wrong, but
I gather that the built-into-the-kernel equivalent is putting
append="ide2=ata66 ide3=ata66" in lilo.conf (and running lilo to
install). No change.

Other mentions imply that Promise 20269 support is in the 2.5 kernel.
Nothing conclusive, but I'm not willing to go 2.5 just for this anyway.

Anyhoo, I'd rather settle for EIDE speed, or get a new motherboard, if
either of those would give me access to the 200GB drive. Anyone have
any similar experiences they can relate?

Thanks!
-- Dan



Dan Sanderson wrote:


> I recently got a brand new Maxtor 7200 RPM 200GB hard drive (Maxtor

> 6Y200PO). This is the Maxtor Ultra Series 8MB cache, Ultra ATA/133.

> My BIOS detects it fine as the secondary slave, and Linux assigns it

> /dev/hdd as appropriate. But any attempt to fdisk /dev/hdd results in

> "Unable to open /dev/hdd," and /var/log/messages to log "hdd: driver

> not present." I'm using kernel 2.4.18-bf2.4 (Debian 3.0). Does

> anyone have any ideas on what "driver not present" means in this

> context? Anyone know what I might be missing?

>

> The drive came with an Ultra ATA/133 PCI card, which I haven't tried

> yet and originally assumed was optional. This has given me the

> impression that UDMA is rather new, at least relative to my

> motherboard (please correct me if I'm wrong). So I'm learning about

> Ultra DMA a little after the fact. The Linux UDMA Mini-Howto ([1])

> says UDMA should be backwards compatible with EIDE (without the UDMA

> bus speed), and I shouldn't have to do anything special to get it to

> work. I don't know much about my motherboard except that it's at

> least a few years old and reports itself as "Via Apollo Pro PCISet" on

> start-up (which I assume close to this:

> http://www.via.com.tw/en/apollo/PRO.jsp). The mini-howto mentions a

> possibly old problem with "TX Pro and other 'Pro' boards," but I don't

> know enough to know if that applies here, and by now I'm probably way

> off track.

>

> I haven't tried using the PCI card yet, but the mini-howto implies

> there's a chance that it might just work, assigning drives to

> hde-hdh. I'm not optimistic; the card comes with "Windows-only"

> drivers, which reeks of being too new to work with Linux. I've been

> tempted to get a new motherboard and processor for a while now, so

> maybe this is a good excuse?

>

> Any other thoughts? Anyone got a favorite ATX motherboard they want

> to plug? (I'm terrible with motherboards. Lately it seems like the

> motherboard/CPU purchasing decision and compatibility issues have

> gotten even more complicated, but maybe it's just me.)

>

> Thanks, all!

> -- Dan

>

> [1] UDMA mini-howto:

> http://www.linux.org/docs/ldp/howto/mini/Ultra-DMA.html

>

>




More information about the Linux mailing list