[linux] x-windows problems-please help

Michal michalg at gmail.com
Wed Dec 8 12:26:46 PST 2004


On Wed, 8 Dec 2004 11:45:42 -0800, Laurel Rees <lrees at u.washington.edu> wrote:

> I tried the suggestion below of logging in at runlevel 3 then doing an

> export KDE and that wasn't successful. I get the same blank screen with

> mouse control that I did with gnome.

>

> I tried deleting everything in two different users' home directories, and

> again both users could not log in on the local machine with the gnome or KDE

> window manager. Both users can log in at runlevel 3. Both users can connect

> remotely.

>

> When I am at the local machine and I log in as root I can use the gnome and

> KDE window manager. There are no problems as root.


Look into the /tmp directory. Specifically look for files owned by
user "lrees". Their names may start with ".", so use "ls -la" to see
them. Remove (or just move to be safe) those files out of the way and
see if it helps. Various gnome daemons leave state files in /tmp, and
the state they indicate may not be accurate any more.

Also:

What it sounds like may be happening is that either gnome-session is
starting, but getting stuck, or just never starting. The mouse cursor
will remain as what it was set to by GDM (that's the Gnome Display
Manager) and not the traditional "X" iconic reminescent of the
situation when no window manager is running.

Before logging in, choose "safemode" session from the GDM interface.
Then log in. This should start a single xterm and not attempt anything
else. In the xterm window, run 'gnome-session' and see what it says.

Besides all of this, what are the contents of the .xinitrc file in
your home directory? If such a file does not exist, try making it with
a single line:

xterm

Then try to log in through the graphical interface (GDM). You should
get an xterm from which you can run various programs like
'gnome-session'.

-Michal



More information about the Linux mailing list