[linux] x-windows problems-please help

Garrett Cooper youshi10 at u.washington.edu
Wed Dec 8 13:19:13 PST 2004


Like I suggested before, could you check the X log for errors or
warnings? I seriously wonder if it's an issue with X itself and not gnome.
Once again, the log would be /var/log/X[something].0.log or something along
those lines. This would be helpful in determining if it's an X issue, or a
gnome issue.
-Garrett

----- Original Message -----
From: "Laurel Rees" <lrees at u.washington.edu>
To: "'Linux/Unix Users Group at the UW'" <linux at u.washington.edu>
Sent: Wednesday, December 08, 2004 11:45 AM
Subject: RE: [linux] x-windows problems-please help



> I tried the suggestion below of logging in at runlevel 3 then doing an

> export KDE and that wasn't successful. I get the same blank screen with

> mouse control that I did with gnome.

>

> I tried deleting everything in two different users' home directories, and

> again both users could not log in on the local machine with the gnome or

KDE

> window manager. Both users can log in at runlevel 3. Both users can

connect

> remotely.

>

> When I am at the local machine and I log in as root I can use the gnome

and

> KDE window manager. There are no problems as root.

>

> Laurel E. Rees

> Senior Computer Specialist

> Dept. of Medical Education and Biomedical Informatics

> v:(206)616-0969

> lrees at u.washington.edu

>

> -----Original Message-----

> From: linux-bounces at mailman1.u.washington.edu

> [mailto:linux-bounces at mailman1.u.washington.edu] On Behalf Of Joshua

Daniel

> Franklin

> Sent: Tuesday, December 07, 2004 12:18 PM

> To: Linux/Unix Users Group at the UW

> Subject: Re: [linux] x-windows problems-please help

>

> Laurel Rees wrote:

> > I can connect remotely to my Red Hat Enterprise workstation machines, I

> can

> > log in locally in init level 3, but when I attempt use the x-windows log

> in

> > I get a nice blue screen (not a BSD) and have mouse ability but the full

> > desktop never comes up. Below is the text from /var/log/messages.

>

> Hmm, sounds like maybe:

> * something weird in your $HOME/.xinitrc or similar

> * the full desktop it's trying to start isn't installed (i.e., no GNOME)

>

> You might backing up then deleting everything (especially hidden .files)

in

> your home directory and trying again. Also maybe make sure the GNOME stuff

> is all installed with Red Hat's install tool. I think its

> system-config-packages or System Settings->Add/Remove Applications. Oh,

but

> if you can't get a X login that won't work... you might try KDE from

> runlevel

> 3 with:

>

> [username at localhost ~]$ export DESKTOP=kde

> [username at localhost ~]$ startx

>

>

> > I am confused why it says uid=0 and my pid is not 1221.

>

> This just means that the application opening the X session

> (gdm in this case) is running as root (uid=0) and its pid, or

> "process ID", is 1221. Nothing to worry about, gdm has to run

> as root in order to authenticate. I also think the pam_unix

> failure is normal when using pam_krb5.

>

> > I have my Red Hat boxes set up to authenticate to the UW servers (don't

> know

> > if this is relevant).

> >

> > Dec 6 13:20:51 babysbreath gdm(pam_unix)[1091]: authentication failure;

> > logname= uid=0 euid=0 tty=:0 ruser= rhost= user=lrees

> > Dec 6 13:20:53 babysbreath gdm-binary[1091]: pam_krb5: authentication

> > succeeds for `lrees'

> > Dec 6 13:20:54 babysbreath gdm(pam_unix)[1091]: session opened for user

> > lrees by (uid=0)

> > Dec 6 13:20:55 babysbreath gconfd (lrees-1221): starting (version

2.2.1),

> > pid 1221 user 'lrees'

>

>





More information about the Linux mailing list