[linux] A linux distro for my Athlon64

Doug McLean dougmc at u.washington.edu
Tue Oct 26 09:27:43 PDT 2004


That's why I couldn't install Fedora. I tried it last night (by passing
the kernel parameter you mentioned) and it installed correctly!

You are a genius. :)


>From there, I was able to download the kernel I needed and use it.


Still, I think SuSE might be a welcome choice too. I found some of the
backend stuff kind of confusing in the past, but everyone who has ever
used it loved the hardware support.

Doug McLean
CSS Systems Administrator
University of Washington, Bothell
http://staff.washington.edu/dougmc/pgp.html

Meanwhile, in Gotham, zanfur at zanfur.com wrote:


> It's not free, but SuSE 9 and SuSE 8 Enterprise both work remarkably well

> on the Athlon64 platform, on the K8T chipset. It's what the PogoLinux

> 1264's use. (I've personally installed this distro on about a hundred of

> the buggers.)

>

> I know from experience that FC2 works on that chipset as well, but there

> are some issues with DMA on the SATA controllers, and even on some PATA

> controllers. "Issues" range from simply not using DMA to glorious crashes

> with lots of pretty blinking lights on the screen. Fortunately, there are

> kernel updates that fix this problem, if you can get it installed in the

> first place. I got around this problem by turning off DMA in the bios,

> installing FC2 that way (very, very slowly), updating every rpm (using

> yum) to the most current -- most importantly, the kernel -- and then

> turning DMA on. just remember to pass the nodma option to the kernel

> while installing.

>

> Cheers!

> -robin

>

>

> On Mon, Oct 25, 2004 at 03:02:31PM -0700, Doug McLean wrote:

>> Hi guys,

>>

>> It's been a little while since I posted to this list.

>>

>> I recently bought/assembled an Athlon64 machine (with an MSI FSR 800 mobo,

>> VIA K8T chipset). I have a serial ATA drive on there, with some space to

>> throw Linux on there, but I also have a legacy IDE hard drive that at one

>> point had Slackware on it.

>>

>> At this point, I want to put something Linux-y on this machine so I've

>> tried:

>>

>> Fedora Core2 (at first i386, then later for 64-bit Athlons)

>> FreeBSD 5.2.1 (the 64-bit Athlon port)

>> Slackware 10 (this just flat out didn't work)

>>

>> All of them run into various problems installing themselves on either the

>> SATA drive or on the legacy IDE drive. The problems all stem from

>> problems writing to the drives, or reading from the CD-Rom drive (which

>> like the IDE drive has worked on other computers with Linux). I kept the

>> IDE drive installed thinking that maybe something could at least get

>> installed there, but I run into problems nevertheless. I think the

>> Motherboard is the issue.

>>

>> I think I have to wait a bit for Linux support for my motherboard to catch

>> up, but being impatient, I was wondering if anyone had any experience

>> getting Linux to work in a stable way on Athlon64 systems, especially with

>> MSI boards.

>>

>> Does anyone recommend a distro (including FreeBSD) that potentially will

>> have the best support in the future?

>>

>> Thanks all!

>>

>> Doug McLean

>> CSS Systems Administrator

>> University of Washington, Bothell

>> http://staff.washington.edu/dougmc/pgp.html

>



More information about the Linux mailing list