Re: [linux] sldapd upgrade, starts fine, but package manager thinks it is not configured

Matt Weatherford mbw at uw.edu
Thu Mar 3 11:49:13 PST 2011


Maria,

Have u tried a:

Dpkg-reconfigure slapd

Or
aptitude remove slapd-dbg

Or

Aptitude remove slapd

Then install it again? Debian won't delete your config files.

Matt


Maria McKinley <parody at u.washington.edu> wrote:

Greetings,

I just upgraded my ldap server from Lenny to Squeeze, but slapd did not restart.

Starting OpenLDAP: slapd ESC[31mfailed!ESC[39;49m
invoke-rc.d: initscript slapd, action "start" failed.
dpkg: error processing slapd (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of slapd-dbg:
slapd-dbg depends on slapd (= 2.4.23-7); however:
Package slapd is not configured yet.
dpkg: error processing slapd-dbg (--configure):
dependency problems - leaving unconfigured

I managed to fix the problem with the slapd configuration. The TLSCipherSuite was originally set to this:

TLSCipherSuite TLS_DHE_RSA_AES_256_CBC_SHA
TLSCipherSuite TLS_RSA_3DES_EDE_CBC_SHA1

Which I had changed to get around a bug that happened if I set it to HIGH in the last version, but I digress. I have now changed the suite to NORMAL, and slapd starts up and works just fine. But, the package manager still thinks it is not configured yet. What should I do? It is complaining about being unable to move stuff to backups, but I am a little afraid that if I get rid of stuff in this directory, it will move stuff and break my newly working slapd.

Errors were encountered while processing:
slapd
slapd-dbg
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up slapd (2.4.23-7) ...
Backing up /etc/ldap/slapd.d in /var/backups/slapd-2.4.11-1+lenny2... done.
Moving old database directories to /var/backups:

Backup path /var/backups/dc=shadlen,dc=org-2.4.11-1+lenny2.ldapdb exists. Giving up...
dpkg: error processing slapd (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of slapd-dbg:
slapd-dbg depends on slapd (= 2.4.23-7); however:
Package slapd is not configured yet.
dpkg: error processing slapd-dbg (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
slapd
slapd-dbg

thanks,
maria

--

Maria Mckinley

Scientific Programmer
Shadlen Lab
Physiology and Biophysics
Box 357290
University of Washington
(206) 616-3923
parody at u.washington.edu


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman13.u.washington.edu/pipermail/linux/attachments/20110303/98407327/attachment.html>


More information about the Linux mailing list