[statnet_help] Problems with valued ergm

Mumenthaler, Fabian Fabian.Mumenthaler at phbern.ch
Mon Sep 28 10:23:10 PDT 2020


Dear all,

I am having problems with calculating valued ergms and would really appreciate your help.
I’m getting an error message that I don’t understand. In [statnet_help] the same error message appeared in “Valued models with missing edges”. As far as I grasp it, there is something else causing the same message. I only have one missing edge and when I impute the modal value for this NA the same error occurs.

Description of the data:
It’s a school class of 16 pupils. Nodeattributes are gender, age, special educational needs status [IS], and self-concept in sports. The dependent variable are interactions in Physical Education with 0 = almost no interaction up to 4 = interact very often.

The ergm command is:
est <- ergm(playNet ~ sum + mutual("min") + nodeisqrtcovar + nodeosqrtcovar
+ nodematch("gender", diff = F, form = "sum")
+ nodeifactor("IS", base = 1) + nodeofactor("IS", base = 1)
+ transitiveweights("min", "max", "min"), response= "count",
reference=~Binomial(4))

The error message I get is:

Error in if (is.null(message) && nonnegative && any(nw %e% response < :

missing value where TRUE/FALSE needed



> playNet


Network attributes:

vertices = 16

directed = TRUE

hyper = FALSE

loops = FALSE

multiple = FALSE

bipartite = FALSE

total edges= 145

missing edges= 1

non-missing edges= 144



Vertex attribute names:

age gender IS sport vertex.names



Edge attribute names:

count



> sessionInfo()


R version 4.0.2 (2020-06-22)

Platform: x86_64-w64-mingw32/x64 (64-bit)

Running under: Windows 10 x64 (build 18363)



Matrix products: default



locale:

[1] LC_COLLATE=German_Switzerland.1252 LC_CTYPE=German_Switzerland.1252

[3] LC_MONETARY=German_Switzerland.1252 LC_NUMERIC=C

[5] LC_TIME=German_Switzerland.1252



attached base packages:

[1] stats graphics grDevices utils datasets methods base



other attached packages:

[1] statnet_2019.6 tsna_0.3.1 sna_2.5 statnet.common_4.3.0

[5] tergm_3.6.1 networkDynamic_0.10.1 ergm.count_3.4.0 ergm_3.10.4

[9] network_1.16.0



loaded via a namespace (and not attached):

[1] magrittr_1.5 MASS_7.3-51.6 tidyselect_1.1.0 lattice_0.20-41

[5] R6_2.4.1 rlang_0.4.7 fansi_0.4.1 dplyr_1.0.2

[9] tools_4.0.2 parallel_4.0.2 grid_4.0.2 nlme_3.1-148

[13] lpSolve_5.6.15 cli_2.0.2 coda_0.19-3 ellipsis_0.3.1

[17] assertthat_0.2.1 tibble_3.0.3 lifecycle_0.2.0 crayon_1.3.4

[21] Matrix_1.2-18 purrr_0.3.4 vctrs_0.3.4 trust_0.1-8

[25] glue_1.4.2 robustbase_0.93-6 compiler_4.0.2 DEoptimR_1.0-8

[29] pillar_1.4.6 generics_0.0.2 pkgconfig_2.0.3


> getOption("pkgType")


[1] "both"


I attached the example data and the full R-code to this email.
Do you have any suggestions of what I’m doing wrong? Any help is much appreciated!

Thanks and best wishes,
Fabian

*Fabian Mumenthaler*
PhD Student, Social participation of Students with SEN in inclusive classes with focus on sports
Department of Special Education, University of Teacher Education Bern, Switzerland
fabian.mumenthaler at phbern.ch<mailto:fabian.mumenthaler at phbern.ch>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman13.u.washington.edu/pipermail/statnet_help/attachments/20200928/91cd0739/attachment.html>


More information about the statnet_help mailing list